For ArcGIS 9.x

Q1. I don’t have the .NET Framework, can I still use GeoWEPP? 

No. Several of the components that GeoWEPP uses are built into VB.NET executable files. At this time, you need to have the .NET framework installed on your computer. Microsoft has a free download that will install this for you, just click here and follow the directions.

Q2. GeoWEPP’s tool buttons don’t respond.

There have been a few incidents recently that a security program such as Norton Antivirus or McAfee detected GeoWEPP’s execution file(s) as threat and removed it. Please pay attention to a security message while installation. If a security application removed a file(s), please restore the file(s) or remove the file(s) from the application’s threat list and re-install GeoWEPP.

Q3. I don’t have the .NET Framework, how do I get it? Microsoft has a free download that will install the .NET Framework for you, just click here and follow the directions.

Q4. I received a “Unable to locate dll. The dynamic link library <insert dll here> could not be found in the specified path” error. What does that mean?

Your computer does not have the .NET framework installed on it. Without the .NET Framework, GeoWEPP will not run. Microsoft has a free download that will install the .NET Framework for you, just click here and follow the directions.

Q5. I have tried a number of CSA and MSCL combinations, but GeoWEPP says a network can’t be created.

The TOpographic PArametriZation software (TOPAZ) used to delineate the stream channels will not be able to create a network if there are “holes” in the DEM. TOPAZ classifies a “hole” as being any cell that has an elevation value less than 1 and greater than 9999. GeoWEPP analyzes your DEM and fills in any “holes” it finds (and reports to you where these were found). Sometimes, TOPAZ still finds holes; these are more like phantom holes since there doesn’t appear to be a hole in the DEM.

To determine if this is the case, open the folder that contains your current project’s files (for example, C:\ArcGeoWEPP\Project\My_Project2). Right-click on the file “DEDNM.RPT” and open with notepad. If there is an error, it will be located at the end of the file. If the report states that a value that is not between 1 and 9999 as been found, you have a hole.

To fix this, reduce the size of your DEM. In most cases, you actually have a much larger DEM than you need. Clip the DEM so that it only or mostly contains your study area. Convert the DEM to ASCII and try GeoWEPP again.

Another reason why this may occur is that you have installed GeoWEPP within a folder with a space in the name (for example: “My GeoWEPP”). TOPAZ uses DOS to execute all of its commands and, like most older DOS programs, it doesn’t like spaces in the pathnames. The most common occurrence of this is when GeoWEPP folder is located on the Desktop. All you need to fix this is to move the entire folder to a new location.

Q6. When I run the “flowpath method” or the “watershed and flowpath method”, I get a “soil type not defined at row _ and column _” error or a “management type not defined at row _ and column _” error and the program hangs, crashes, or no results are displayed. If I run the “watershed only method” on my study site, I get results and no problems. Why does this occur? What can I do to correct this? 

The short answer is that your watershed is too large; use a smaller watershed. The long answer involves the flowpaths within the watershed and the amount of RAM your computer has. During the “flowpath method” portion of the run, GeoWEPP and WEPP simulate every possible flowpath within the watershed and compile the results. This takes a lot of memory; if you run out of memory you get the error and the results can not be compiled.

Well, how many flowpaths can I have in my watershed before it becomes a problem? Unknown. The amount of memory used depends on the number and the length of the flowpaths. We ran a simulation on a 1m DEM; when we had just over 10,000 flowpaths, GeoWEPP would crash. If we had under 10,000 flowpaths, We would get results (512MB of RAM). This value will change depending on the number of other programs running at the same time; the more programs running, the less flowpaths you can run.

What should I do? There are two ways you can handle this, depending on your personality. If you are the type that wants a definite answer, have a plenty of time, and don’t mind pulling your hair out, then you can try running simulation after simulation to determine what the maximum size watershed you can use for your current study. If you are like everyone else, the best way is to run the “watershed only method” on your study area to determine where your problem areas are within your watershed. Then run GeoWEPP simulation on those areas; since these will be smaller areas, your flowpath runs should work fine.

Will this get fix? Part of the problem is the memory intensive functions involved; there is not much that can be done with this. We are currently working on a solution that will allow a user to run GeoWEPP on larger watersheds that will bypass this problem, but we are still in the initial development phase of this procedure.

Q7. I have just selected my outlet point. A DOS window appears and begins to repeat the same thing over and over again. What is wrong? How do I fix it? 

Once you have selected an outlet point, GeoWEPP sends that points location to TOPAZ to create the subcatchments within the watershed. This point can not be located at the beginning of a channel or at a converging point, or TOPAZ will not be able to create the subcatchments. When one of these points are selected, TOPAZ will find the error and run a continuous loop stating the error. To stop this loop, close the DOS window. Then go to your current working directory and delete the “NotDone2.txt” file. This will stop the process. You can now select another point.

Steps have been made to prevent this from occurring by analyzing the point you select before it is passes on to TOPAZ. But some points do slip by for some reason. We are currently looking into why this occurs and should have a solution in the future.

Q8. After I select my climate, GeoWEPP states “User Canceled Run. WEPP Run Canceled.” What’s going on here? 

It appears that the Translator will only read text files that are in ANSI format, not in Unicode-8. Double check how your text files were create. If they are in UNICODE-8, either convert it or try to rewrite it.

Q9. I have installed and tried to run GeoWEPP. When I either finish inputting my own ASCII data or after I click the example set I wish to use, GeoWEPP does some stuff and then stops. What happened? 

In most cases, your pathways for ArcGIS are not set up properly. Here is a simple test: Go to the project folder you just created (either the example folder in the Example_Sets folder or your own folder in the Projects folder). Find the ArcGeoWEPP.mxd file and double click on it. Once the MXD opens, click [OK] in the message box. Most likely, you’ll see a number of error messages and only have a topographic image layer. If this is the case, the pathway is set up incorrectly.

To solve this, all you need to do is; 1) Determine the correct pathway for ArcGIS (it would be the folder that contains ArcToolbox), 2) Delete GeoDirInfo.txt, and 3) Start GeoWEPP. When prompted, enter the correct pathway. The defaults given are the default installs for ArcGIS and for WEPP.

Q10. When click PRISM, there is an error saying “cannot find bluebook.sum”.

If your operating system is 64bit, you can download a utms.exe program for your 64bit operating system here: (sometimes this webpage doesn’t work,  needs to be refreshed) and copy the PRISM_Files folder to your project folder.

Q11. How can I solve the “ECCloseSta” error which appears when I click the PRISM button?

You can generate a climate file by using the link: and download the file when modification is completed. Load the climate file once you accepted the watershed.

Q12. Error message: Error when start using the .exe. The operation was canceled by the user.

A: This happens when the .exe is forced shut down by the Operating System (OS). It could be caused by non-administrative operation or UAC (User account control). If you are working on a computer without using an administrator account (e.g. computers in your university or company), please work on a computer that allows you to use administrative account (e.g. your personal computer). If you have logged in to your computer with administrative account, then it could be caused by the UAC. The UAC will ask you if you would like to continue using the .exe. Please click ‘Yes’ to let the .exe runs. If this problem happens even after you clicked ‘Yes’, try lowering your UAC security in the control panel of your OS.